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About Jive Anywhere

Jive Anywhere combines the endless information of the Internet with the collaborative power of Jive.

To get work done, you need to interact with many different web sites and web applications. For example,

you approve invoices, review job candidates, or research on the Web. When you come across something

you need to discuss in Jive, such as a candidate in LinkedIn, you can now use Jive Anywhere to connect

all the Jive conversations. In one place, everyone in your community can converge on this one subject.

Jive Anywhere brings Jive collaboration directly into the context of any web site or web application. For

instance, as you review a sales opportunity with a CRM system, you can see if anyone in your company

has already been discussing the company. With a Jive Anywhere click, you can create a group in your Jive

community to discuss the opportunity with colleagues.
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Jive Anywhere System Requirements

This topic specifies the required and supported system elements for Jive Anywhere.

Jive Anywhere requires Jive 6 and higher or Jive Cloud. Check out our Jive Anywhere Feature

Compatability Matrix to learn about Jive Anywhere features available with each EAPIs version.

Supported Browsers

• Safari 5.1 and higher (OSX only)

• Internet Explorer 8, 9*, and 10** for Windows only

• Google Chrome***

• Mozilla Firefox***

Note:

* Snapshots and the ability to zoom out are available in the Jive Anywhere view of your community

when using Internet Explorer 9 and higher. (The exception is when you're using IE 9 in quirks mode,

which is a browser technique used for maintaining backwards compatibility with web sites using old,

non-standard html markup.) In Internet Explorer 8, you can use original size and fit-to-page views in

the Jive Anywhere view.

** The ability to upload file attachments and embed images using OWA, Gmail, or Google Drive are

available in the Jive Anywhere view of your community when you're using Internet Explorer 10 and

higher.

*** The Google Chrome and Mozilla Firefox browsers are released frequently. Jive Software makes

every effort to test and support the latest version.

Supported Operating Systems

• Mac OSX

• Windows XP SP2 (Windows Installer 3.1)

• Windows Vista

• Windows 7

• Windows 8*

Note:  * For Windows 8, only Internet Explorer in the desktop version is supported. For Internet

Explorer 10, enhanced protected mode (EPM) must be disabled, which it is by default. To edit this

setting, navigate to Tools > Internet options > Advanced.

Other

• .NET Framework 3.5 SP1 or 4.x Client profile (required for Internet Explorer)

https://community.jivesoftware.com/docs/DOC-93514
https://community.jivesoftware.com/docs/DOC-93514
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Managing Jive Anywhere

Jive Anywhere brings conversation, content, and context into Jive from anywhere you are on the Web.

Jive Anywhere integrates any web page or web application with your community. With Jive Anywhere, you

can start a conversation, or see what everyone else has already said, about any Web content. Best of all,

there's absolutely no code required. It just happens automatically. IT doesn't have to be burdened with

another integration.

To begin, all you need to do is install the Extended API (EAPI) plugin in Jive, configure Jive Anywhere, and

provide the Jive Anywhere browser plugin for your community.

Discuss with your entire community

We've made it simple to post discussions to the entire community. All you have to do is select Entire

Community when choosing where to post your discussion, and it will be visible to everyone in the

community. This feature replaces posting to the root space.

Installing the Extended API JAR File

The Extended APIs plugin JAR file can be downloaded from the Jive Software web site. This plugin

supports multiple Jive products including this one. After you add this plugin, you'll need to restart Jive in

order for the feature to become available.

Once you download the plugin JAR file, install it using the following steps:

1. In the Admin Console, go to System > Plugins > Add Plugin.

2. Under Install a new plugin, click Browse to select and open the plugin JAR you downloaded

3. Click Upload to add it to the community.

4. Restart the application as root: /etc/init.d/jive-application restart. For a cluster

installation, restart each node.

5. Once the application has restarted, you can verify that the plugin was installed by navigating to

System > Plugins > Installed Plugins and checking the list for the Extended APIs plugin. This is also

where you can remove the plugin.

6. Finally, go to System > Settings > Extended APIs and ensure the modules you want are enabled.

Post-Installation Configuration
After you install the Extended APIs plugin, you need to perform the post-installation configuration steps to

get Jive Anywhere to work the way you want.

After installing the Extended APIs plugin, configure Jive using the following settings:

• For Extended APIs, if your environment blocks unauthenticated traffic using proxy and SSO, then you

need to allow /__services/eapis/version/current without any authentication header.
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• Enable OAuth.

• Deploy browser plugins to multiple users.

• Restrict web sites that use Jive Anywhere.

• If you want to enable auto-updates, allow outgoing network access through the firewall to

files.jivesoftware.com.

Enabling OAuth
OAuth is the authentication method for Jive Anywhere.

OAuth provides a process for client users to authorize third-party access to their server resources without

sharing their credentials (typically, a username and password pair), using user-agent redirections.

To enable OAuth, configure the following settings in your company's proxy and firewall:

• Allow #JIVESERVER#/api/oauth2/* calls without any authentication headers.

• Accept the oauth2 authorization header as a valid and authenticated call to the server. For example,

Authorization: oauth2 xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Deploying Browser Plugins to Multiple Users

After you download the Windows Installer file, JiveAnywhere.msi, you can deploy the browser plugins to

multiple users on Windows as long as they're using Internet Explorer or Firefox. Chrome and Safari are not

supported. This mass deployment requires .Net Framework 3.5 SP1 or .NET Framework 4.0 Client Profile .

For large scale enterprise deployments, you can use tools such as Microsoft Group Policy or Microsoft

System Center Configuration Manager.

To perform a silent installation of the client, type the following operation in a Command window while

logged in as an admin:

msiexec.exe /i "JiveAnywhere.msi" /qn SERVERURL="https://your-jive-

instance.com" ADDLOCAL=IE,FIREFOX

ADDLOCAL Specifies which browsers you want to install

passing parameters using the ADDLOCAL

argument. Removing ADDLOCAL installs Jive

Anywhere on any Internet Explorer or Firefox

browser by default by default.

SERVERURL Sets the desired Jive instance.

Restrict the Web Sites that Use Jive Anywhere
You can provide a list of sites where Jive Anywhere exclusively works (an inclusion list) or a list of sites

where you want Jive Anywhere to be unavailable (an exclusion list).
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Extended APIs 2.0 and higher allow community admins to create inclusion and exclusion lists in the Jive

Anywhere Admin Console page. If you are using the Extended API 1.0 version, you can create these lists

by using system properties created for them as describe in Using the Extended APIs 1.0 Plugin.

Using the Extended APIs 2.0 and Higher Plugin

The inclusion/exclusion list of sites that use Jive Anywhere are controlled by a list that you enter in the Jive

Anywhere Admin Console page.

Fastpath:  Admin Console: System > Settings > Jive Anywhere

To include or exclude sites that use Jive Anywhere:

1. Click the Restricted Sites tab.

2. Type the list of sites, using a comma to separate them. For example, you might type:

www.jivesoftware.com, www.yourwebsite.com

Note:  Make sure you don't use the "http://" part of the URL in the Property Value field.

3. Select Inclusion or Exclusion depending on which list you're creating.

4. Click Submit.

Using the Extended APIs 1.0 Plugin

You can create inclusion and exclusion lists using two system properties:

extended_apis.jiveanywhere.is_inclusion Use this property to specify which web sites can

use Jive Anywhere.

extended_apis.jiveanywhere.restriction_list Use this property to restrict Jive Anywhere's access

to certain web sites. For example, you may want

remove Jive Anywhere from your community pages

because there's no reason to create a community

discussion about a community discussion.

Use the following steps to access and configure these properties.

Fastpath:  Admin Console: System > Management > System Properties

To include or exclude sites that use Jive Anywhere:

1. Scroll down to the Add a New Property section.

2. Enter extended_apis.jiveanywhere.is_inclusion in the Property Name field.

3. Set the Property Value to False for an exclusion list or True for an inclusion list.

4. Click Save Property.

5. Add the web site list by adding another property with that information:
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a. Enter extended_apis.jiveanywhere.restriction_list in the Property Name field.

b. In the Property Value field, type the list of web site URLs to include or exclude from using

Jive Anywhere. Separate the web site URLs using a semicolon. For example, you might type:

www.jivesoftware.com; www.yourwebsite.com

Note:  Make sure you don't use "http://" part of the URL in the Property Value field.

c. Click Save Property.

Disable Auto Updates on Internet Explorer
Disable the auto-update feature and update notifications for Jive Anywhere in Internet Explorer by adding a

registry key and deploying it to all users on a domain.

To disable the auto-update feature and update notifications:

Windows (32-bit) If you are running 32-bit Windows, then log into

a Command window as admin and type this

operation:

REG ADD HKLM\SOFTWARE
\BrowserExtensions
\c21f6d90-6844-484d-
b0ee-309021dd83eb /v
 IsUpdateDisabled /d true /t REG_SZ

Windows (64-bit) If you are running 64-bit Windows, then log into

a Command window as admin and type this

operation:

REG ADD HKLM\SOFTWARE
\Wow6432Node\BrowserExtensions
\c21f6d90-6844-484d-
b0ee-309021dd83eb /v
 IsUpdateDisabled /d true /t REG_SZ

Note:  For large scale enterprise deployments, you can use tools such as Microsoft Group Policy or

Microsoft System Center Configuration Manager.

Create Your Own Jive Anywhere Cartridge
Create a new Jive Anywhere cartridge and add it to Jive using the Admin Console.

You can customize how Jive Anywhere interacts with web pages by creating a new or adding an existing

cartridge. A cartridge provides deeper integration between Jive, Jive Anywhere, and a web site. You can

create a Jive Anywhere cartridge by using the Jive API. For more on this, see the Jive Anywhere 2.1

Cartridge SDK.

http://files.jivesoftware.com/JiveAnywhere/downloads/JiveAnywhereSDK_2.1.zip
http://files.jivesoftware.com/JiveAnywhere/downloads/JiveAnywhereSDK_2.1.zip
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Fastpath:  Admin Console: System > Settings > Jive Anywhere

1. Click Cartridges > Upload new cartridge. The Module dialog opens.

2. Type the name of the cartridge in the Display Name field.

3. Click Browse to upload the zip you created when you followed the instructions in the Jive Anywhere 2.1

Cartridge SDK.

4. In the last text box, type the include pattern you want to add, then click the up arrow to add it to the

Cartridge Include Patterns field.

5. Click Submit.

http://files.jivesoftware.com/JiveAnywhere/downloads/JiveAnywhereSDK_2.1.zip
http://files.jivesoftware.com/JiveAnywhere/downloads/JiveAnywhereSDK_2.1.zip
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Troubleshooting Jive Anywhere

Troubleshooting

Using Internet Explorer 9, but still unable to use

the Snapshot feature on internal web sites

If you want snapshots to work on internal web sites,

then you can do one of the following:

• Change the default document mode by adding

(or replacing) the following metadata line to the

HTML header:  <meta http-equiv="X-UA-

Compatible" content="IE=edge" />

• Make the web pages HTML5 by declaring the

HTML using the following: <!DOCTYPE html>

Others cannot reply when content is posted to

Entire Community

If you want to make sure others can comment

on content you post from Jive Anywhere to the

entire Community, you need to open the content for

editing and then save it. You don't need to actually

make any changes to it.
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